Fiber_Nexus: OSPF & MPLS lab

  • Posted on 2015-07-25 09:53:57
  • 742 Views
  • 1 Uptweets
  • 0 Favorites
  • 0 Likes
  • 1 Dislikes

Welcome,

I am glad you are here ready to learn a bit more today. I can honestly say learning and remembering all these networking protocols and commands are not easy. The biggest challenge in the real world is time. When you are hired for your first networking job whether its an entry level engineer job or an administrator, quick and timely decisions are very important! When there is an outage and your customers, clients, or even co-workers have no internet or voice service, time is your biggest challenge. You won't have much time to go over your notes to check and find what the issue might be before you have your customers asking for an update and requesting the network to be restored immediately. But at the end of the day, trial and error is the best teacher. With that being said, I wanted to talk about two very important protocols that many ISPs use, MPLS and OSPF. OSPF is the most popular routing protocol because it is not proprietary and it is very flexible. Just to remind new students, these protocols are just "rules" of how you want to route traffic within your network. The same way the streets and highways are designed with off-ramps, traffic lights, left turns, right turns, merges, and you have to follow the law or "rules" according to your city, that is the same way routing protocols are designed. The routers use highways of traffic with rules set in place so traffic can be routed smoothly, safely, and to it's destination. At the end of the day, it's up to you and the company to decide what " rules" you want to implement into your network. The same with MPLS, instead of making the routers verify each packet, it already knows what is the next destination based on its labels. I made this small lab so you can have an idea of how it works and how you can troubleshoot it in real life. Cell Backhaul has a similar setup although it is more advanced and I will add the rest of the configs with VRFs and mBGP next time. It is not the best design of course but at least you have an idea of how it is set up and what the commands look like. My best advice is to create a lab of your own changing the configs so you can practice the CLI commands better. Also, you would need to study and learn basic MPLS and OSPF if you haven't done so through Cisco's book and videos. Youtube and CBT Nuggets also have a lot of videos. In the picture below, that is the way the network is setup in GNS3 using the 7200 Cisco image. You would have to copy and paste each SMOP depending on the ###ROUTER### name and interface. If you are able to use the 7200 image with Gigabit interfaces, this should work smoothly. If not you can edit the SMOP based on what you have. Here are some basic show commands to use. Enjoy this lab!

show mpls ldp neighbor

show mpls ldp bindings

show ip route ospf

show ip ospf int brief

show ip ospf neighbors

show ip ospf int


#####ROUTER 1######
!
hostname nexusR1
!
ip cef
!
no ip domain-lookup
!
!

mpls ldp router-id lo 0
mpls label range 100 199
mpls ip
!
interface Loopback0
ip address 61.61.1.1 255.255.255.255
ip ospf 60 area 0
!
!
interface gigabitEthernet 1/0
description Connected_nexusR3
ip address 68.86.0.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
interface gigabitEthernet 3/0
description Connected_nexusR4
ip address 68.86.3.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
router ospf 60
router-id 61.61.1.1
passive-interface default
no passive-interface gigabitEthernet 2/0
no passive-interface gigabitEthernet 3/0
mpls ldp sync
mpls ldp autoconfig area 0
log-adjacency-changes
area 0 authentication message-digest
network 68.86.0.1 0.0.0.0 area 0
network 68.86.3.1 0.0.0.0 area 0
end
wr

######ROUTER 2######
!
hostname nexusR2
!
ip cef
!
no ip domain-lookup
!
!

mpls ldp router-id lo 0
mpls label range 200 299
mpls ip
!
interface Loopback0
ip address 61.61.1.2 255.255.255.255
ip ospf 60 area 0
!
!
interface gigabitEthernet 2/0
description Connected_nexusR3
ip address 68.86.1.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
interface gigabitEthernet 4/0
description Connected_nexusR4
ip address 68.86.2.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
router ospf 60
router-id 61.61.1.2
passive-interface default
no passive-interface gigabitEthernet 2/0
no passive-interface gigabitEthernet 4/0
mpls ldp sync
mpls ldp autoconfig area 0
log-adjacency-changes
area 0 authentication message-digest
network 68.86.1.1 0.0.0.0 area 0
network 68.86.2.1 0.0.0.0 area 0
end
wr

#####ROUTER 3#####

!
hostname nexusR3
!
ip cef
!
no ip domain-lookup
!
!

mpls ldp router-id lo 0
mpls label range 300 399
mpls ip
!
interface Loopback0
ip address 61.61.1.3 255.255.255.255
ip ospf 60 area 0
!
!
interface gigabitEthernet 2/0
description Connected_nexusR2
ip address 68.86.1.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
interface gigabitEthernet 1/0
description Connected_nexusR1
ip address 68.86.0.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
router ospf 60
router-id 61.61.1.3
passive-interface default
no passive-interface gigabitEthernet 2/0
no passive-interface gigabitEthernet 1/0
mpls ldp sync
mpls ldp autoconfig area 0
log-adjacency-changes
area 0 authentication message-digest
network 68.86.0.2 0.0.0.0 area 0
network 68.86.1.2 0.0.0.0 area 0
end
wr

######ROUTER 4##########


!
hostname nexusR4
!
ip cef
!
no ip domain-lookup
!
!

mpls ldp router-id lo 0
mpls label range 400 499
mpls ip
!
interface Loopback0
ip address 61.61.1.4 255.255.255.255
ip ospf 60 area 0
!
!
interface gigabitEthernet 3/0
description Connected_nexusR1
ip address 68.86.3.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
interface gigabitEthernet 4/0
description Connected_nexusR2
ip address 68.86.2.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 n3xu5
ip ospf hello-interval 5
ip ospf dead-interval 30
ip ospf 60 area 0
mpls ip
no shut
!
router ospf 60
router-id 61.61.1.4
passive-interface default
no passive-interface gigabitEthernet 4/0
no passive-interface gigabitEthernet 3/0
mpls ldp sync
mpls ldp autoconfig area 0
log-adjacency-changes
area 0 authentication message-digest
network 68.86.2.2 0.0.0.0 area 0
network 68.86.3.2 0.0.0.0 area 0
end
wr




0 /0 Comments

Post By:

@fiber_nexus