OSPF Virtual-Links & Point-to-Point

  • Posted on 2015-07-28 03:50:22
  • 951 Views
  • 0 Uptweets
  • 0 Favorites
  • 0 Likes
  • 0 Dislikes

Welcome,


I am here thinking of that one time I posted a video on Instagram about Virtual-Links but I did not post an explanation about it. Well today I wanted to give you an idea of what it is and how easy it is to implement. Also, I am throwing in here some Point-to-Point OSPF connections and how they are useful. I see many Point-to-Point OSPF links here at work so I wondered what the benefits are. Let's start off with what is a Virtual-Link. In OSPF, Area 0 is the backbone area of your network and every area must somehow connect to it directly. But what can you do if you add another OSPF area to an area that is not Area 0? Tricking OSPF. You have to make it think that it is directly connected to Area 0 so you must create a tunnel that skips the area between Area 0 and your foreign area. In the topology below, you see that I marked a "blue dotted tunnel" from Area 3, through Area 1, and connecting into Area 0. The way to do that is by adding a simple command to point to each others loopback address in the OSPF process. In this case, I used the command area 1 virtual-link 3.3.3.3 on R2 and area 1 virtual-link 2.2.2.2 on R3. I also added OSPF authentication as you can see. To make sure it works, you must see this notification: %OSPF-5-ADJCHG: Process 555, Nbr 3.3.3.3 on OSPF_VL2 from LOADING to FULL, Loading Done. Once you see this adjacency you will be able to advertise traffic from Area 3 across Area 1 into Area 0. In this topology I added 2 Virtual-Links and made sure you can ping from R1 to R6 through several OSPF areas. This would happen if you have too many routers in OSPF Area 0 and Area 1. That is rare but it is good to know this command for your Cisco studies.

Now let's talk about Point-to-Point OSPF links. The normal OSPF network you would probably learn from CCENT or CCNA is broadcast OSPF, which means you will have a Dedicated Router and Backup Dedicated Router, DR/BDR. If you see this topology, you might just want to not have a DR/BDR so you force OSPF to point to one direction only. You add the ip ospf network point-to-point command under the interface using OSPF. Now there are more differences between broadcast and point-to-point OSPF networks. Broadcast networks establish an adjacency much slower than point-to-point and generates around 50% more LSAs. This causes slow convergence as you can see in this chart:
BROADCAST

POINT-TO-POINT

Network: Hello: DeadInterval: Adjacency time:
Broadcast 10s 40s 40s
Point-to-Point 30s 120s 2s

As you can see, the Hello & Dead Intervals for an OSPF Broadcast network is much faster! but it is much slower to make an adjacency. So how can you tweak that? Well you add the ip ospf network point-to-point command and also ip ospf hello-interval 10 & ip ospf dead-interval 40 commands under the interface. That way you will have the same Hello/DeadInterval time as a Broadcast network and an even better adjacency time than a broadcast network. Tweaking the times would make a Point-to-Point link really fast in all areas. You can see all the in the configs that I posted below regarding Virtual-Links and a Point-to-Point OSPF network. Well hopefully you learned something today and I will see you soon!

###ROUTER 1###
config t
!
hostname nexusrouter1
!

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 555 area 3
!
interface GigabitEthernet1/0
ip address 78.86.1.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 3
ip ospf hello-interval 10
ip ospf dead-interval 40

!
router ospf 555
router-id 1.1.1.1
log-adjacency-changes
area 3 authentication message-digest
passive-interface default
no passive-interface GigabitEthernet1/0
network 78.86.1.1 0.0.0.0 area 3
maximum-paths 32
end
wr


####ROUTER 2####
config t
hostname nexusrouter2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 555 area 1
!
interface GigabitEthernet1/0
ip address 78.86.1.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 3
ip ospf hello-interval 10
ip ospf dead-interval 40
!
interface GigabitEthernet2/0
ip address 68.86.0.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 1
ip ospf hello-interval 10
ip ospf dead-interval 40
!
router ospf 555
router-id 2.2.2.2
log-adjacency-changes
area 1 authentication message-digest
area 1 virtual-link 3.3.3.3 authentication message-digest
area 3 authentication message-digest
network 78.86.1.2 0.0.0.0 area 3
network 68.86.0.2 0.0.0.0 area 1
end
wr

###ROUTER3###
config t

hostname nexusrouter3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 555 area 0
!
!
interface gigabitethernet3/0
ip address 68.86.4.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 0
ip ospf hello-interval 10
ip ospf dead-interval 40
!
interface gigabitethernet2/0
ip address 68.86.0.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 1
ip ospf hello-interval 10
ip ospf dead-interval 40

!
router ospf 555
router-id 3.3.3.3
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
area 1 virtual-link 2.2.2.2
network 68.86.0.1 0.0.0.0 area 1
network 68.86.4.1 0.0.0.0 area 0
end
wr

###ROUTER4###
config t

hostname nexusrouter4

!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 555 area 0
!

interface gigabitethernet3/0
ip address 68.86.4.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 0
ip ospf hello-interval 10
ip ospf dead-interval 40
!
!
interface gigabitethernet4/0
ip address 68.86.3.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 2
ip ospf hello-interval 10
ip ospf dead-interval 40
!
router ospf 555
router-id 4.4.4.4
log-adjacency-changes
area 0 authentication message-digest
area 2 authentication message-digest
area 2 virtual-link 5.5.5.5
network 68.86.3.2 0.0.0.0 area 2
network 68.86.4.2 0.0.0.0 area 0
end
wr

####ROUTER5####
config t

hostname nexusrouter5
!

!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip ospf 555 area 2
!
!
interface gigabitethernet5/0
ip address 78.86.2.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 4
ip ospf hello-interval 10
ip ospf dead-interval 40
!
interface gigabitethernet4/0
ip address 68.86.3.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 2
ip ospf hello-interval 10
ip ospf dead-interval 40
!
router ospf 555
router-id 5.5.5.5
log-adjacency-changes
area 2 authentication message-digest
area 2 virtual-link 4.4.4.4 authentication message-digest
area 4 authentication message-digest
network 68.86.3.1 0.0.0.0 area 2
network 78.86.2.1 0.0.0.0 area 4
end
wr

###ROUTER6####
config t
hostname nexusrouter6
!

interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip ospf 555 area 4
!
!
interface GigabitEthernet5/0
ip address 78.86.2.2 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf 555 area 4
ip ospf hello-interval 10
ip ospf dead-interval 40
!
!
router ospf 555
router-id 6.6.6.6
log-adjacency-changes
passive-interface default
no passive-interface GigabitEthernet5/0
network 78.86.2.2 0.0.0.0 area 4
maximum-paths 32
end
wr
















0 /0 Comments

Post By:

@fiber_nexus